
A/ Software installation 
  

1) Install IviumSoft from CD: 
 
Use the "setup" application on the IviumSoft 
installation CD and follow instructions. IviumSoft 
will be installed on your C- or D-drive (default) in 
the "IviumStat" directory. This directory will 
include example data files, drivers, Labview 
example and all manuals. Also a shortcut to 
IviumSoft will be placed on your desktop.  
 

B/ Connecting your instrument 

The CompactStat can be used in USB- or adapter-
powered mode. When using adapter-powered 
mode, the correct order is to first insert the 
adapter plug and then connect the USB-cable.  

• For all other Ivium-potentiostats, first insert the power cable, 
then connect the USB-cable. Next, switch the instrument on.  

• 

All Ivium potentiostats have a unique serial number that is connected with the device 
driver. The first time the potentiostat is connected to a specific computer, the driver 
will be loaded. Normally this will go automatically and take a few moments. If 
prompted (Windows XP), choose "automatic" installation and to "continue anyway". 
After the driver has been loaded, the IviumSoft can be started and the device serial 
number is visible in the readout window at the top left of the user interface. 

C/ Software – user interface 
 
1. Device & software control 
2. Operating parameters 
3. Advanced parameters 
4. Measurement results 
5. Legend panel 
6. Data file history list 
7. Status bar 
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1. Device & software control 
 
The menu bar: 
 
 File  - Data and method file management. 
 Options - Setting the device and data handling options, incl. FRA options 
 Tools - Device maintenance and special operations 
 Help - HTML help file: content sensitive and topic search 
 About - Shows IviumSoft version and corresponding .dll [no#] 
 
 
 
 
 
 
 

To start:  
a. In the drop down menu select the device by Serial Number. 
b. To operate this instrument, click "Connect". 

2. Operating parameters 

"Direct" mode: for direct control of the instrument 
 
• Intended for diagnostic purposes 
• Actual potential and current are displayed 
• When not controlled, the open cell potential is displayed  
   (within specified accuracy) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
"Method" mode: for executing electrochemical methods. 
 
 
 

Example:  
a. Select configuration, i.e. "Cell Estat4". 
b. Select current range 
c. Insert value 
d. Press "Apply" 
e. Check connect-box: cell on/off 

 
  
 
f. Above: 
 DC/AC - to toggle between AC/DC signal measurement 
 IRcorr - will open IR-drop correction window 
 HiSens - will make hi-sensitivity current ranges available 
g. Below: direct control of the peripheral port and FRA are 

possible.  

Example: 
a. Select desired method from the tree: 
 Expand method group and select method. 
b. The relevant method parameters are listed and accessible 

in the window below. 
c. Once the relevant parameters are inserted the 

measurement can be started by clicking the "Start" 
 button at the bottom of the window. 
d. Clicking the "Abort" button will abort the measurement 

immediately at the next data point.  
e. When preconditioning before measurement is set up, 

directly after clicking "Start" a "Continue" button will 
appear. Clicking this will terminate the preconditioning and 
proceed to start the method. 

f. Upon finishing and/or aborting of a measurement all data 
is automatically saved in the selected project, with an 
automatically generated file name. 

g. When all method parameters are set to appropriate values, 
this method can be saved for future use by selecting "File" 
in the upper menu bar and choosing "Save method".  

h. From Menu > File previously saved methods and data files 
can be loaded. When loading a data file also the 
corresponding method is loaded. Clicking "Start" will re-
run the same experiment. 

 

3. Advanced parameters 

• In "Method" mode, by default the basic parameters are 
shown. Selecting "Advanced" from the drop down menu 
will add a number of advanced method parameters. 
 
 
 
 
 
• Indicators: the grey indicators will light up red when 

the corresponding parameter reaches an overload. The 
black indicator shows the actual current range in use 
(useful when automatic current ranging is active). 
 
• "SigView" opens a window that shows voltage and  

current signal trace during an AC measurement, as 
well as for saved impedance data points. Can be 
used to verify the quality of the signal and to 
check for e.g. overload/oscillation situations. 

 

4. Measurement results 

•When a measurement is started the data is shown real time in the 
result graph. A right mouse click on the graph will give the user a 
number of options, including changing the graph colour and 
background, as well as copying the graph to clipboard. 
 
• The buttons to the left allow additional data to be displayed. Data is 

by default displayed "2D"; "3D" and "3Di" display may also be 
chosen. Clicking the "Cor" button after the measurement has 
finished, will start the correction mode, allowing the user to change 
individual data-points. "X" shows the primary data, "Ain, ocp, pre, 
Q, Rs, Cs" will all open a second graph that shows the 
corresponding data when available: optional analog inputs, ocp-
measurement before scan, pre-treatment data, etc. 
 
• The "Scale" button allows the scale of the graph to be adjusted via 

the drop down menu; clicking on the button itself will auto-scale 
the graph.  
 
• "Analysis" will make a number of analysis methods available to the 

data in active memory.  
 
• "Edit" will allow smoothing of the scan data. 

 
• The buttons at the top of the graph activate different 

representations of (impedance) measurement data. 
 
• The tabs "Result graph" and "Result data" above the graph enable 

switching between graphical and numerical representation of the 
scan data. "E scan" will show the data for analysis when an 
impedance-scan method has been carried out. 

5. Legend panel 

 
"Scan" shows the list of scans that have just been measured or loaded from memory. 
 "Hide all"/"Show all" will respectively hide and show all scans in the list. 
 In the list of scans, checking/unchecking the box next to the scan will show/hide 

individual scans. Note that the scan that is highlighted blue is the scan in active 
memory. This is the one that is evaluated in "Analysis", or has the numerical 
data shown in "Result data", etc. Clicking on a different scan will select that one 
(highlight it), making it available for analysis, saving, etc. 

 Checking the box before "Hide previous" will hide all previous scans, except the 
latest (useful when a large number of scans is listed). 

 "All extra data" will show the extra data, for example OCP measurement, of all 
scans in the list. 

 "Delete" will remove the selected scan from the view screen only*. 
 "Delete all" will remove all scans from the view screen only*. 
   *Data is always automatically stored in a datafile and cannot  

  be permanently deleted from the Legend panel 
 "Data appear" will allow user to change the appearance of the data: lines, 

colours, symbols.  
 
"Olay" will allow the user to load data from file and overlay it so that it can be  
 compared to the scan data that was just recorded. Several scans can be overlayed 
at the same time. All the same options apply as in the scan-tab. Overlayed data is  

 not available for analysis. 
 
The "Chan" tab shows when analog inputs are sampled (advanced method 
parameter), it allows the user to show/hide analog channels in the second graph. 

Three tabs: 
1) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2) 
 
 
 
 
3) 

Note that: 
- A scan in the list can be selected (highlighted in blue), but not be visible in the 

graph, and vice versa. 
- When different electrochemical methods are used, the data cannot always be 

represented in the same graph (i.e. CV and EIS data). For this reason, the format 
of the most recent scan in the Legend panel is automatically displayed and only 
compliant scans are shown. Non-compliant scans are hidden.  

- Running a CV-scan will automatically clear the graph of all present scans when the 
next experiment is started; other methods will add the new scan to the Legend 
panel. 
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• 

 
  

2) Pre-Install Drivers: 
 
Navigate to the newly created directory: ..\IviumStat\iviumdrivers and 
run "Ivium_driverinstaller.exe" to install 2 Ivium instrument drivers. 
When prompted click "next"; then at the Windows Security pop-up click 
"Install this driver software anyway"; upon completion click "Finish".  
 
You can now connect your instrument via USB. The pocketSTAT is USB powered: connect the delivered USB cable  between 

pocketSTAT and PC/Laptop and the instrument is ready to operate. 

• 
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• The "Project window" shows the active Project directory 
in which data files are automatically stored. Select your 
Project directory from the drop down menu. When typing 
a new Project name in the window, it will automatically 
be created when the next data file is stored. 

NOTE: Windows 8/10 may block third party 
drivers; in your new IviumStat\Manuals and 
Release Notes folder, refer to the document: 
T2 Ivium Driver Installation.pdf 
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• "BatchMode" opens the batch programming window. 

This can be used for automating and sequencing 
measurements, scheduling events, etc. For 
instructions, refer to the Technote "T1 Batch mode..." 
in your "IviumStat\Manuals and Release Notes" 
directory. 
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D/ Special operations  

From the top menu "Tools" will open a list of  special operations:  

"Performance test"  (only available when an instrument is connected) 

"Performance test" will open a pop-up window that allows a 
self-diagnostic test of the instrument. This test is intended for 
occasional use, for example to determine if the calibration is 
still correct or whether the instrument is in proper working 
order. At a service request you can be asked to run this test 
by an Ivium service engineer to determine if the problem is 
hardware related. The performance test can only be executed 
when the instrument is in the "standard" configuration (= no 
extended range or other options activated). 
 
To run the test, connect the cell cable to Testcell1, uncheck all 
options in the menu "Options>Options", and run the test. All 
status reports should read "Pass". If one, or more, reads "fail" 
after repetitive runs, the instrument may need calibration. 
This cannot be done by the user, you should contact your 
supplier. 
 
The test report is stored in your\Iviumstat directory as a text 
file with the file name: [Serial number].ipt  

"Pulse generator" 

"Pulse generator" is a direct function that will apply a pulse 
according to the selected parameters: 
 
 
 
 
 
 
 
 
 
 
 
By selection, a potentiostatic or galvanostatic pulse can be 
generated with user selectable height and duration. The pulse 
generator is intended for preparation/conditioning of a 
sample. Data is not measured or stored. 

"Current Interrupt" 

"Current Interrupt" will open a window that allows use of the 
Ivium Current Interrupt module (CIM). The CIM can be 
purchased separately. The current interrupt technique can be 
used to determine the ohmic drop of an electrochemical 
system. This value can then be used for ohmic drop 
compensation during various electrochemical methods. 

E/ Software & Firmware upgrade 

IviumSoft upgrade 
 
IviumSoft is frequently updated with new features, often at a customer's request. When a new version of 
IviumSoft is available, it is published on our website at: www.ivium.nl/Support. Here the new version can be 
downloaded as .zip file. The .zip file contains the IviumSoft.exe and whatever auxiliary files necessary. Note 
that this does NOT contain a full installation package, so using this file for a new installation is not possible. 
 
To upgrade the IviumSoft, download the latest version of the software from www.ivium.nl/Support. Open the 
.zip file and copy all files to clipboard. Browse to your IviumStat file folder: ..\IviumStat, and paste (replace 
the files already there with the new ones). 
 
Now your IviumSoft has been upgraded. After this proceed to upgrade the firmware of your instrument. 
 
Firmware upgrade 
 
Ivium instruments are equipped with an internal micro PC that operates the electronics, and is used to store 
data during a HiSpeed experiment. The firmware that runs on the micro PC is specific to the version of 
IviumSoft. For correct communication (and operation) these versions need to match, that is why IviumSoft 
has the correct version of firmware embedded. To upgrade the firmware of your instrument: 

6. Data file history list 

All Ivium experimental data is automatically saved upon completion or user-abort of a measurement. A data file is 
created with an automatically generated file name, including a unique scan id and instrument S/N. After the data 
is saved to file in the active project, it will be added to the history list of most recent data files at the bottom of 
the user interface. 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

Double clicking on a file in the history list will load that file into the result window. Holding the [Shift] key will allow 
multiple data files to be selected simultaneously. A right mouse click will open a pop-up: 
 
• Load Scans: will load selected scans into the result window. 
• Add Scans: will add selected scans to the result window and the scans already there. 
• Add Overlays: will load selected scans to the result window but into the Olay tab, in stead of the Scan tab. 
• Copy files: will copy data file to clipboard, for example for easy pasting into an e-mail, or a file directory. 
• Add to Bookmarks: will add the selected scan to the bookmarks for future reference. Book marked scans can be 

identified by their underline. All bookmarked files in the history list can be shown by clicking [Bmrks] to the left 
of the history list. 
• Move to active project: will move the data file to the active project (see 3. Advanced parameters). 
• Move to tempfiles: will move the data file to the tempfile directory. Data files in the "tempfile" project are 

displayed in red. 
• Delete permanently: will delete the data file permanently. 
 
 
Data Storage: 
Data files are stored in a Library\project structure. In the menu "File>Data Explorer" data files in all 
libraries and projects can be explored, with a list of method parameters and result graph preview. In 
the menu "Options>Datahandling Options" the data storing options can be specified, such as: timed 
intermediate saving, automatic storage of a file copy to another designation (i.e. network drive), temp 
file properties, etc.  

"Define channels" 

"Define channels" is only available for the Ivium-n-Stat: it will open a pop-up window that allows the user to 
assign the channel serial number to a channel number for easier designation and reference. Details on how to 
do this can be found in the IviumSoft Help 'Getting started>Ivium-n-Stat'. 

1. Connect to your instrument in the IviumSoft and go to 
"Tools>Device maintenance" 
 

2. In the pop-up window click on "Firmware upgrade" 
 

3. In the second pop-up click "Start", let the file 
upload, and when finished (successfully uploaded) 
click "Close". 
 
 
 
 
 
 
 
 

4. After this, click "Reboot device". 
 
 

5. Then close IviumSoft and restart your instrument. 
 

For more instructions refer to Technote T4: "Software 
and Firmware Upgrade". 
 

After an experiment is completed and the datafile is stored, the user can enter a description 
and click "Apply" to store the description in the view of the history list. 

Checking the bookmark box and pressing "Apply" will bookmark the 
selected datafile for future reference. Bookmarked files are underlined. 

7. Status bar 

The Status bar is located at the bottom of the user interface. Depending on the status of the instrument (idle, 
running a method, etc.) and/or the method that is running, a series of parameters is shown. 

In the case of a CV scan (see figure above) it shows the real time E, I, number of acquired data points so 
far, cycle number, elapsed runtime of the scan and the notification that a measurement is in progress (or 
completed). When, for example, an OCP measurement is included in the method, the measured final 
reference OCP value is also shown in the status bar. During an impedance measurement the real time E 
and I, the current frequency of the datapoint measured and the percentage of progress are displayed. 

In addition to the brief overview of the IviumSoft user interface that is given in this Quick guide, in-depth 
information is given in the digital help file/manual that is included in your IviumSoft. There you will find 
instructions on the installation of potentiostats and modules, their instrument specifications, and how to operate 
them. In addition detailed information on how to use IviumSoft and all its functions regarding operating all 
electrochemical techniques and measurement methods, data representation and evaluation, etc., is described. 
 
To access the digital help file/manual open your IviumSoft and press "F1". The help file is partly content sensitive 
so indicating with your cursor an area or subject in the IviumSoft user interface and subsequently pressing "F1" 
will open the helpfile on the relevant subject. 
  
In the help file/manual the subjects are structured in main chapters according to: 
  
 Electrical Compliance 
  
 Introduction 
  
 IviumSoft 
  
 
 
 Getting started 
  
 
 
 
 Instrument control 
  
 
 
 
 
 Electrochemical  
 techniques 
  
 
  
  Measurement Results 
  
 
 Data files 
  
 
 Special functions 
  
 
 Software upgrade 
  
 Control via  
 other software 
  
 Trouble shooting 
  
  
 Instrument 
 specifications 
   
  Method parameters 
  
 
 
  
NOTE 1:  
It may be that when you open the helpfile the content is not visible, or you see a cryptic browser message like 
"Navigation to the webpage was cancelled" or "Action cancelled". This is caused by Windows and can be fixed 
simply by changing a setting: In Windows explorer navigate to your IviumStat directory where the help file is 
located. Right-mouse-click on the 'IviumSoft.chm' file and choose 'Properties' at the bottom of the list. This opens 
a pop-up. In the bottom panel of the pop-up click "Unblock" and OK. Close the pop-up window. Now the content in 
the IviumSoft help will be available. 
  
NOTE 2:  
The help file/manual covers current IviumSoft and instruments and operations. If you have specific operating or 
instrument specification questions regarding older versions of Ivium instruments, please contact Ivium. 
 
NOTE 3: 
A (printable) PDF-version of the digital IviumSoft Help is available in the 'Manuals and Release Notes' directory in 
the 'IviumStat' installation directory on your PC. 

F/ Manual in Help-file 

Declaration of CE conformity of Ivium instruments. 
  
Brief description of Ivium, our instruments and the working principle of IviumSoft. 
  
Detailed description of IviumSoft: how to operate the software, instructions on the 
user interface, data representation and options, how to select and set instrument 
options and operations. 
  
Instructions for first time installation: IviumSoft and Ivium equipment, instrument 
drivers and configuring your Windows system, product-specific information for all 
Ivium potentiostats and modules, how to connect the electrodes and internal 
integrated dummy cells. 
  
Description of how the user can control Ivium potentiostats through IviumSoft: 
directly for diagnostic purposes or via user selectable electrochemical methods; how 
to program a sequence of events in the Batch programming mode; special 
instrument functions; sequence of execution of the various commands by the 
potentiostat. 
  
Brief description of all available electrochemical techniques (for detailed descriptions 
the electrochemical textbooks should be consulted), grouped by: 
Linear sweep, Cyclic voltammetry, Transients (CA, CP, ECN, MixedMode: versatile 
combination of transients and sweeps), Electroanalysis, Impedance, Corrosion. 
  
How to access and represent the measured data (graphic and numeric), as well as 
the various available data evaluation techniques and possibilities. 
  
How and where data files are stored and accessed; the structure of projects and 
libraries; the handling of very large data files and automatic saving of data. 
  
Special operations for (instrument) diagnostics and maintenance, preparatory 
techniques and use of the peripheral port signals and functions. 
  
Instructions for IviumSoft upgrade. 
  
Description on the software development driver and dll for control via other software 
such as Labview, C++, VB, etc. 
  
How to solve some of the most frequently encountered issues and how to restore 
your potentiostat. 
  
Specifications of all Ivium instruments, modules, accessories and their compatibility. 
 
 
Detailed description of all method parameters. 
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